Document Signing Disruption
Incident Report for Pike13
Resolved
This has been resolved. Please email help@pike13.com if you have any issues.
Posted Feb 09, 2023 - 10:52 PST
Investigating
Our partner for providing document signing service is experiencing a disruption. We are working with them to resolve this issue and will provide an update here when the problem is resolved.
Posted Feb 09, 2023 - 08:40 PST
This incident affected: 3rd Party Integration.