Email Delivery
Incident Report for Pike13
Resolved
Email has been restored. Emails that should have been sent from midnight to noon PST Friday 8/18 may not be delivered as expected.
Posted Aug 18, 2023 - 12:46 PDT
Investigating
Pike13 is not currently delivering emails. We are investigating this issue and will update this page as possible.
Posted Aug 18, 2023 - 07:48 PDT
This incident affected: Notifications (Email).