Payment processing problems
Incident Report for Pike13
Resolved
This incident has been resolved.
Posted Sep 27, 2017 - 09:42 PDT
Update
Credit card and ACH transactions are working. Will continue to monitor.
Posted Sep 27, 2017 - 07:50 PDT
Monitoring
Our payment processor reports that they are restoring availability, there may still be intermittent failures.
Posted Sep 27, 2017 - 07:42 PDT
Identified
Our payment processor is having connectivity issues, credit card and ACH payments may not work
Posted Sep 27, 2017 - 06:58 PDT